Given an array of length N and an integer x, you need to find if x is present in the array or not. Return true or false. Do this recursively.

PROBLEM
:-
Check Number
Send Feedback

Given an array of length N and an integer x, you need to find if x is present in the array or not. Return true or false.

Do this recursively.

Input Format :
Line 1 : An Integer N i.e. size of array
Line 2 : N integers which are elements of the array, separated by spaces
Line 3 : Integer x
Output Format :
'true' or 'false'
Constraints :
1 <= N <= 10^3
Sample Input 1 :
3
9 8 10
8
Sample Output 1 :
true
Sample Input 2 :
3
9 8 10
2
Sample Output 2 :
false
SOLUTION:-
#include<iostream>
using namespace std;


bool checkNumber(int input[], int size, int x) {
  /* Don't write main().
     Don't read input, it is passed as function argument.
     Return output and don't print it.
     Taking input and printing output is handled automatically.
  */
    if(size==0)
        return false;
    else{
    if(input[size]==x)
        return true;
    else{
        checkNumber(input,size-1,x);
    }
    }

}
int main(){
    int n;
    cin >> n;
  
    int *input = new int[n];
    
    for(int i = 0; i < n; i++) {
        cin >> input[i];
    }
    
    int x;
    
    cin >> x;
    
    if(checkNumber(input, n, x)) {
        cout << "true" << endl;
    }
    else {
        cout << "false" << endl;
    }
}


Previous
Next Post »

If you have any doubts then please let me know... ConversionConversion EmoticonEmoticon